[ECOS] Serial communications

grahamlab graham.labdon@cranems.co.uk
Fri Jul 10 12:55:00 GMT 2009




Nick Garnett wrote:
> 
> grahamlab <graham.labdon@cranems.co.uk> writes:
> 
>> Thanks for the info Nick
>> 
>> Well I got an old PC with 2 serial ports and loaded Linux.
>> 
>> LOW and BEHOLD it worked
> 
> While I appeciate this has all been a PITA for you, I cannot help
> feeling relieved that this was not a problem with the STM32 serial
> drivers itself :-/
> 
> If nothing else, this has provided a useful pointer to why things
> might not be working for others in the future. Virtual environments
> are becoming more common, but it is clear that they leave something to
> be desired in the area of real time behaviour (as one would expect, to
> be fair).
> 
> -- 
> Nick Garnett                                       eCos Kernel Architect
> eCosCentric Limited    http://www.eCosCentric.com       The eCos experts
> Barnwell House, Barnwell Drive, Cambridge, UK.      Tel: +44 1223 245571
> Registered in England and Wales:                         Reg No: 4422071
> 
> 
> -- 
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
> 
> 
> 
Thanks for the advice given, if nothin else I have learnt alot!!
I have just started another thread -I am trying to get cygwin working but
when I execute the arm-eabi-gdb command I get returned to the command prompt
immediately
any ideas?

-- 
View this message in context: http://www.nabble.com/Re%3A-Serial-communications-tp24354870p24427037.html
Sent from the Sourceware - ecos-discuss mailing list archive at Nabble.com.


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list