[ECOS] problem with gdb from eabi tooolchain

Jonathan Larmour jifl@eCosCentric.com
Tue Jan 20 18:51:00 GMT 2009


Dave Milter wrote:
> I use jtag, emacs and precompiled eabi 4.x  gcc toolchain recently
> posted in this list.
> 
> And I have problem with gdb,
> time to time it print:
> 
> /home/test/src/toolchains/gdb/gdb-6.8.50.20080706/gdb/findvar.c:298:
> internal-error: value_of_register_lazy: Assertion `frame_id_p
> (get_frame_id (frame))' failed.
> 
> And after that I can not work with it.

Download
ftp://ecos.sourceware.org/pub/ecos/gnutools/i386linux/ecoscentric-gnutools-arm-eabi-20081213-sw.i386linux.tar.bz2

Unfortunately, I thought the version strings had got updated but they
weren't, which means there's no way to tell which version you've got :-(,
but if you have this problem, then you probably have the older 20081107
build so try this one.

Jifl
-- 
eCosCentric Limited      http://www.eCosCentric.com/     The eCos experts
Barnwell House, Barnwell Drive, Cambridge, UK.       Tel: +44 1223 245571
Registered in England and Wales: Reg No 4422071.
------["Si fractum non sit, noli id reficere"]------       Opinions==mine

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list