[ECOS] Redboot run image issues

Chris Zimman czimman@bloomberg.com
Sun Feb 22 21:20:00 GMT 2009


> If i run the same image by loading it to ram from a JTAG(BDI3000), it
> works just fine.
> I am not able to understand what is the difference when i run the same
> image from JTAG and when i do a "run" from a already running image.

You need to provide more information on *what* it is that you're loading.
What Gary was asking is if it's an ELF file, SREC, etc. that you're loading
versus a flat binary image.  If you're not aware of which type it is, running
'file' on it will tell you.

Can you post the exact command you're giving the BDI to load the image?
For the avoidance of doubt, I'm not asking for 'load' or 'load image', but
rather 'load [mem address] image [bin | elf | srec]' -- like the full line.

--Chris

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list