[ECOS] ecos + lwip

Mandeep Sandhu mandeepsandhu.chd@gmail.com
Thu Aug 27 13:51:00 GMT 2009


>
> Well there was actually a mistake. I did compile sio.c even when serial
> support is not needed (no SLIP or PPP). The warnings in socket.h should not
> matter, but I'll look into them.
>
>> $ find packages/ -name serialio.h
>> packages/io/serial/v3_0/include/serialio.h
>
> Headers in the eCos repository will not be found when compiling, only the
> headers which are copied over to your build tree are recognized.
>
> Well I fixed the bug with sio.c
>
> Here is the fixed release:
> http://download.westlicht.ch/lwip-20090827-1.tar.gz

Thanks!

>
> Copy all the archives files over the existing files in your eCos repository.
> Then use the following to build:
>
>> mkdir testbuild
>> cd testbuild
>> ecosconfig new linux lwip_eth_sequential
>
> Note: If you want to build with i386-elf toolchain you need to edit ecos.ecc
> and change the user_value for CYGBLD_GLOBAL_COMMAND_PREFIX from "" to
> "i386-elf"

Yup. I'm doing that already.
>
>> ecosconfig tree
>> make
>> make -C net/lwip_tcpip/current tests
>
> If this does not compile without errors there is something wrong with your
> setup. What is your environment?

I'm running Ubuntu 9.04. Using the i386 toolchain that comes with ecos-3.0

Regards,
-mandeep

>
> Simon
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list