[ECOS] POSIX File IO / time.h not found

Sergei Gavrikov sergei.gavrikov@gmail.com
Wed Apr 8 12:45:00 GMT 2009

Please, do not top post: http://en.wikipedia.org/wiki/Posting_style

On Wed, Apr 08, 2009 at 01:41:08PM +0200, Szentirmai Gergely wrote:
> Hello
> Thanks for your answer, what led me to the solution. I tried ARM7S eval 
> board template, which built successfully. Than I added posix file IO, 
> resolved conflicts, built successfully. Than I added FAT file system 
> support, and resolved conflicts. Than there was the original build 
> error. And the solution was to add POSIX compatibility layer package, 
> which was NOT required by something, maybe FAT support. (posix file IO 
> bulit without POSIX compatibility layer)
> About the arm-elf compiler:
> Several weeks ago, I tried to get gdb alive, I used ecos 2.0 and 
> arm-elf-gcc, open-ocd, windows, cygwin configuration. I was unable to 
> get the arm-elf-gdb, shipped with ecos, working. Then I tried yagarto 

Ups. eCos 2.0 is terribly old.

> tools toolchain, which worked with a standalone project (gdb was also 
> working), but I was unable to build ecos with yagarto, because it uses 
> windows style path, and configtool uses unix style. (building with 
> arm-elf-gcc of ecos, and using gdb of yagarto was not success) Than I 
> tried arm-eabi-gcc. Ecos compiled, but the application built with it, 
> did not work. (It had some wicked behaviour).

eCos 3.0 was carefully tested on Linux and cygwin. I'm sorry, I don't
use cygwin, but a lot of eCosers use it. I agree with that what cygwin
does add new (not eCos related) problems for developers.

> So I "downgraded" back to arm-elf. The gdb still not working, but at 
> least the application does. :)
> This is my short story of cross-compilers, any suggestions are wellcome!

Then use Linux. Just now I'm writing a success story for my vis-a-vis
friend about: eCos 3.0 + OpenOCD (today's SVN trunk) + a cheap parallel
JTAG wiggler from Olimex + arm-eabi-gdb + printf. But, I use Linux.


> Gergely Szentirmai
> Sergei Gavrikov írta:
> >On Tue, Apr 07, 2009 at 09:58:37PM +0300, Sergei Gavrikov wrote:
> >  
> >>On Tue, Apr 07, 2009 at 08:34:12PM +0200, Szentirmai Gergely wrote:
> >>    
> >>>Hello
> >>>
> >>>I tried to added posix file I/O package to my project, but there was an  
> >>>error during build ( cyg/posix/sys/time.h: No such file or directory ).  
> >>>I used ecos-2.0. Then I updated ecos-2.0 to the latest, the problem was  
> >>>still the same. So I downloaded ecos-3.0 final, the problem still 
> >>>persists.
> >>>
> >>>So now I'm using ecos 3.0 final, and the configtool shipped with the  
> >>>package. In the generated folder structure there is no "posix" folder at 
> >>>all!
> >>>
> >>>Does anyone had this error?
> >>>      
> >>The eCos 3.0 tested itself about a few months. It not seems, that
> >>maintainers missed the posix things. What template did you use? Lazy
> >>demos with the latest eCos 3.0 are the below (run on Linux host)
> >>    
> > 
> >[snip the demos]
> >
> >BTW, to add fileio package, you can use default template, no bloat posix
> >template. It's enough to have CYGPKG_LIBC_TIME.  This package is
> >included in eCos default template. Try to build eCos in the clean (new)
> >directories. Also, it's possible that you have a mixture of the eCos
> >repositories or/and GNU toolchains. Check it.
> >
> >
> >Sergei
> >
> >  

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list