[ECOS] POSIX File IO / time.h not found

Sergei Gavrikov sergei.gavrikov@gmail.com
Tue Apr 7 20:30:00 GMT 2009


On Tue, Apr 07, 2009 at 09:58:37PM +0300, Sergei Gavrikov wrote:
> On Tue, Apr 07, 2009 at 08:34:12PM +0200, Szentirmai Gergely wrote:
> > Hello
> >
> > I tried to added posix file I/O package to my project, but there was an  
> > error during build ( cyg/posix/sys/time.h: No such file or directory ).  
> > I used ecos-2.0. Then I updated ecos-2.0 to the latest, the problem was  
> > still the same. So I downloaded ecos-3.0 final, the problem still 
> > persists.
> >
> > So now I'm using ecos 3.0 final, and the configtool shipped with the  
> > package. In the generated folder structure there is no "posix" folder at  
> > all!
> >
> > Does anyone had this error?
> 
> The eCos 3.0 tested itself about a few months. It not seems, that
> maintainers missed the posix things. What template did you use? Lazy
> demos with the latest eCos 3.0 are the below (run on Linux host)
 
[snip the demos]

BTW, to add fileio package, you can use default template, no bloat posix
template. It's enough to have CYGPKG_LIBC_TIME.  This package is
included in eCos default template. Try to build eCos in the clean (new)
directories. Also, it's possible that you have a mixture of the eCos
repositories or/and GNU toolchains. Check it.


Sergei

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list