[ECOS] POSIX File IO / time.h not found

Szentirmai Gergely reg@t-online.hu
Tue Apr 7 18:58:00 GMT 2009


Hello

I tried to added posix file I/O package to my project, but there was an 
error during build ( cyg/posix/sys/time.h: No such file or directory ). 
I used ecos-2.0. Then I updated ecos-2.0 to the latest, the problem was 
still the same. So I downloaded ecos-3.0 final, the problem still persists.

So now I'm using ecos 3.0 final, and the configtool shipped with the 
package. In the generated folder structure there is no "posix" folder at 
all!

Does anyone had this error?

Thank you!
Gergely Szentirmai

arm-elf-gcc -c  
-I/cygdrive/d/Projects/BME/Onlab/ECGDevice/Software/ECG-Eclipse/ECGDevice/ecgdevice_ecos_elf-3-0_install/include 
-I/opt/ecos/ecos-3.0/packages/io/fileio/v3_0 
-I/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src 
-I/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/tests -I. 
-I/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src/ -finline-limit=7000 
-Wall -Wpointer-arith  -Wundef -Woverloaded-virtual -Wno-write-strings 
-mno-thumb-interwork -mcpu=arm7tdmi -g -O2 -ffunction-sections 
-fdata-sections -fno-rtti -fno-exceptions -Wp,-MD,src/select.tmp -o 
src/io_fileio_select.o 
/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src/select.cxx
In file included from 
/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src/select.cxx:68:
/cygdrive/d/Projects/BME/Onlab/ECGDevice/Software/ECG-Eclipse/ECGDevice/ecgdevice_ecos_elf-3-0_install/include/sys/time.h:73:42: 
cyg/posix/sys/time.h: No such file or directory
/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src/select.cxx: In function
   `cyg_tick_count cyg_timeval_to_ticks(const timeval*)':
/opt/ecos/ecos-3.0/packages/io/fileio/v3_0/src/select.cxx:127: invalid 
use of
   undefined type `struct timeval'


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list