[ECOS] Another problem getting going with 3.0

Sergei Gavrikov sergei.gavrikov@gmail.com
Sun Apr 5 07:42:00 GMT 2009


Paul D. DeRocco wrote:
> I've installed 3.0 under Cygwin using ecos-install.tcl, and selected the
> arm-eabi toolchain. If I run arm-eabi-gcc, it doesn't do anything. If I run
> it with the -v option, it tells me that it's spawning cc1plus in the
> appropriate directory. If I manually run cc1plus, it does nothing, and won't
> even respond to --help or an invalid option. The timestamp on cc1plus.exe is
> 2008/12/15 04:25:19, and the size is 7,480,320. Can anyone suggest a
> possible cause?
> 
> And if not, is there a way to re-download the Cygwin arm-eabi toolchain and
> run its installation without re-running ecos-install.tcl and re-installing
> all of eCos 3.0?
 
Hi

I don't use cygwin, but, perhaps, the answers on the eCos site.

http://ecos.sourceware.org/getstart.html

<quote>

Users who have downloaded eCos previously and now wish to download
additional toolchains should re-invoke the eCos installer, specifying
the -t switch on the installer command line as follows:

      sh ecos-install.tcl -t 

</quote>

> By the way, I've also updated Cygwin to the present. I've been able to use
> it to compile 2.0 applications in the past, with the the arm-elf 3.3
> toolchain, and indeed if I run the old cc1plus.exe, it responds normally.
> 

http://ecos.sourceware.org/cygwin.html

<quote>

NOTE: Recent eCos toolchains based on GCC 4.x may fail silently if the
Cygwin package libmpfr1 is not installed.

</quote>

Regards,

Sergei

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list