[ECOS] Re: can't find name of serial device

Robert Brusa bob.brusa@gmail.com
Tue Jun 24 11:40:00 GMT 2008


On Mon, 23 Jun 2008 17:10:56 +0200, Robert Brusa <Bob.Brusa@gmail.com>  
wrote:

> Hi
> I have a pretty basic problem: The example serial uses the function
> err = cyg_io_lookup( "/dev/haldiag", &handle ).
> The program works, but now I want to change it for output on UART 0 of  
> my AT91SAM7X-EK. I have tried everything - such as console, tty0 tty1  
> and other instead of haldiag. It does not work, it always return -2 as a  
> result, telling me it can not find the driver. What is the correct name  
> to use?
>
> Thanks and regards Robert

Meanwhile I went back to the configtool to check if all these drivers are  
indeed in my current configuration. And now I found these mystical  
strings: /dev/ser0, /dev/ser1 and /dev/ttydiag. Hence problem solved.  
Thanks and have a nice evening.
Robert



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list