[ECOS] RAM Images on AT91SAM7s256

Tom Deconinck t.deconinck@gmail.com
Tue Jan 29 12:19:00 GMT 2008


Hi,

As Andrew stated, you will have to alter the startup code for the RAM
image to do the memory remapping so the vectors are located at 0x0.
Look at the ROM startup for reference.
I've done something similar on a AT91SAM7SE512, I used a BDI2000 JTAG
probe to load in my image though.

Regards,

Tom

On Jan 28, 2008 6:19 PM, Alois Z. <alois@gmx.at> wrote:
>
> -
> > > > How are you going to get this image into RAM?
> > >
> > > I thought of useing sam-ba for loading and starting images.
> >
> > O.K. But you need to find out what RAM sam-ba uses so you can avoid
> > it.
> >
> > > > You also need to make sure that RAM is mapped to address 0x0 as well
> > > > as 0x00200000. I know ROM startup does this, but i think RAM startup
> > > > probably does not.
> > > Is this necessary for the vectors to be at the right place?
> >
> > Yes. Without this, all your interrupts are not going to work etc.
> >
> >      Andrew
>
> Thanks that realy helped. So much to learn;-)
> Alois
>
> --
> Psssst! Schon vom neuen GMX MultiMessenger gehört?
> Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger
>
> --
>
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
>
>

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list