[ECOS] Is it posible to use Nano-X packet on Vmware template (i386)?

Hakan Çakiroglu ha_cakiroglu@hotmail.com
Fri Jan 18 05:11:00 GMT 2008



Hi there;

1.situation
I was trying to do the following :


-First build redboot with default settings by using ecosconfig.exe for i386 (working from floopy)
- After that I was building my template (vmware)  (microwindows packet is included) from ecoscofig.exe
 from build library option.
- And I was compiling my demo program (polytest.c) with the help of vmware .ecc 

There was no problem in the building section. 

-After that I am booting my virtual pc (vmware) with redboot 
-And than I am taking my compiled .srec file to booted virtual pc with the command "load a.srec"
-Finally I am giving the command "go" to run the program. 

I was taking error message "cannot open graphics"

I have continued searching.....

I couldnt find anything but I have tried this after;


  2.situation
-I have only changed my template : I have added build complete ecos+microwindows application settings, build microwindows NANOWM and Build microwindows NanoX demos and built it again by selecting build library. 

No problem in built section.

-This time I have sended xx/xx_install/bin/xx.elf to redboot and gived the command "go"
But this time I am taking this output :

Creating System threads
Creating Nano-X server thread
Creating Nano-WM thread
Starting Threads
Starting Nano-X server
Starting Nano-WM
No Video BIOS information at location 0x000A0000
Please use asuitably configured Redboot for bootstrap
Cannot initialise screen


At that position I have two question.

1- In first situation why no threads have started? Is it because of polytest.c ? But it is ok in nanox demos section??? 
2-OK may be it is wrong to compile only polytest.c to see some result but why I am taking this error in the second situation ?? (No Video BIOS information at location 0x000A0000
Please use asuitably configured Redboot for bootstrap
Cannot initialise screen)

I have looked into  /packages/services/gfx/mw/current/src/drivers/scr_ecospcsvga.c
It says: 
............However the video
       BIOS can normally only be called in x86 real mode, not protected mode,
       Currently eCos only runs in protected mode, and has no support for
       briefly switching back into real mode.

Can anyone tell me how to build redboot bootstrap that supports me???

(And I have also tried unchecking OUTPUT TO PC SCREEN and checking switch the display to an alterative video mode. This must be the solution but this time there is no output in my pc screen. )

Can somebody help me????
Thank you...


_________________________________________________________________
Live.com'u deneyin: çevrimiçi dünyanýzý bir araya getirin; haberler, spor, hava durumu ve çok daha fazlasý.
http://www.live.com/getstarted

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list