[ECOS] transfer .srec file onto redboot in ARM

abhishek srivastava just_abhi22@yahoo.co.in
Wed Dec 24 11:50:00 GMT 2008


 sir,
 as i did for i386PC, i tried the same for arm-eabi as well
 but couldnt get the desired result.
 i had successfully generated .srec file........not sure,
 that whether .srec file used to be transferred to redboot in
 target in case of arm or hex??
 when i tried to transfer .srec file to arm board it gave
 folllowing error.....plz ckeck and tell what wrong i did
 this is the message i got on my hyperterminal at host!!
 
 RedBoot(tm) bootstrap and debug environment [ROM]
 Non-certified release, version UNKNOWN - built 11:24:46,
 Dec 24 2008
 
 Platform: Hobby-Robotics LPC2XXX/IH1_PROC_LPC_1
 (ARM7TDMI-S)
 Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.
 Copyright (C) 2003, 2004, 2005, 2006 eCosCentric Limited
 
 RAM: 0x40000000-0x40010000, [0x40005940-0x40004000]
 available
 RedBoot> load -v -m yMODEM
 CCC*** Abort! Attempt to load S-record to address:
 0x00000000, which is not vali
 d
 xyzModem - CRC mode, 1(SOH)/1(STX)/0(CAN) packets, 5
 retries
 RedBoot>

i would also like to know, is there any procedure to use ARM ROM space (512k) to write GUI for graphical LCD? actually my graphial LCD RAM is only of 32K, and i need to have few simple GUI on LCD.

any suggestions please!! 
 
 thank you
 



      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list