[ECOS] FW: Adding flash device using the flash v2 drivers

Alex Lindeijer Alex.L@3D-Perception.com
Sat Dec 20 03:17:00 GMT 2008


Hi
Well our application code is now so board specific that is not so easy
to get it to run on the Python board. 
I gett he same error message "incorrect number of flash devices" with
the flash v2 drivers on the Python.
We'll probably need to isolatet he code and run it on the Python board.
Alex Lindeijer
3D Perception - Senior System Designer
-----Original Message-----
From: Gary Thomas [mailto:gary@mlbassoc.com] 
Sent: 19. desember 2008 16:17
To: Alex Lindeijer
Cc: ecos-discuss@sourceware.org
Subject: Re: [ECOS] FW: Adding flash device using the flash v2 drivers

Alex Lindeijer wrote:
> Hi
> We have a controller card with a MPC8541 on it and a spansion S29GL512
> flash. We used the Python eval board from A&M to start the ecos based
> development. The ecos supplied was base don the legacy v1 flash
drivers.
> We are experiencing some verification problems on certain higher
> addresses when accessing it from our application but everything is OK
> when writing to flash from Redboot.

Can you give details on this?  Can you duplicate the problem
using the Python (A&M MPC8541) board?

-- 
------------------------------------------------------------
Gary Thomas                 |  Consulting for the
MLB Associates              |    Embedded world
------------------------------------------------------------

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list