[ECOS] Philips ISP 1581 Source Code

Vivek-Kumar Gupta vgupta@marvell.com
Fri Sep 28 05:36:00 GMT 2007


This is USB Device Controller Chip : Philips ISP 1581

Regards,
Vivek :-
-----Original Message-----
From: ecos-discuss-owner@ecos.sourceware.org [mailto:ecos-discuss-owner@ecos.sourceware.org] On Behalf Of Vivek-Kumar Gupta
Sent: Friday, September 28, 2007 9:31 AM
To: ecos-discuss@ecos.sourceware.org
Subject: [ECOS] Philips ISP 1581 Source Code

I am using Redboot as boot loader for my ARM based board.
Using Philips ISP 1581 Device Controller Chip. 

Can I get Source Code for this chip in Redboot?
If any one has any pointers please help me.
Thanks in advance.


Regards,
Vivek:- 
-----Original Message-----
From: ecos-discuss-owner@ecos.sourceware.org [mailto:ecos-discuss-owner@ecos.sourceware.org] On Behalf Of Vivek-Kumar Gupta
Sent: Wednesday, September 26, 2007 12:22 PM
To: ecos-discuss@ecos.sourceware.org
Subject: [ECOS] How to Enable USB Slave

I want to enable USB in Redboot. Which is similar to ecos. So writing this email.

I have read http://ecos.sourceware.org/docs-latest/ref/usbs-intro.html
Here it is mentioned that "Easiest way to do this is to enable the configuration option CYGGLO_IO_USB_SLAVE_APPLICATION, 
and the USB device driver and related packages will adjust accordingly"
But I don't know where to modify this.?

I have tried modifying  build/ecos/packages/hal/arm/arm9/edb93xx/current/misc/redboot_ROMRAM.ecm
Add 
      package -hardware CYGPKG_DEVS_USB_D12 current  ; 
            package CYGPKG_IO_USB current  ;
            package CYGPKG_IO_USB_SLAVE current  ;
            package CYGPKG_IO_USB_SLAVE_ETH current  ;

but this is giving me errors :
*************
C CYGPKG_DEVS_USB_D12, "requires" constraint not satisfied: CYGIMP_DEVS_USB_D12_HW_ACCESS_HEADER

Unable to generate build tree, this configuration still contains conflicts.
Either resolve the conflicts or use --ignore-errors
make[1]: Entering directory `/newhome/vivek/linux-crater_1-0-3Redboot/build/ecos/build'
********************

I have checked CYGIMP_DEVS_USB_D12_HW_ACCESS_HEADER in ecos.ecc, 
there is cdl_options for this, but did not understand why compilation is giving error (basically in ecosconfig tree) ? 

do i have to check some header file implementing D12 registers ?

What should I do to resolve this. Any pointers...will help a lot.

Thanks in advance.

Regards,
Vivek :-


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list