[ECOS] error with __cxa_atexit and __dso_handle

Brian Clausing bclausing@dramail.com
Fri Sep 14 20:54:00 GMT 2007


On Fri, 2007-09-14 at 12:16 -0300, Santiago Lafon - Controles S.A.
wrote:
> I want to upgrade my arm-alf toolchan to the latest GNU tools
> 
> Some time ago, i made a toolchain with:
>      binutils 2.14
>      gcc-core 3.3.1
>      gcc-g++  3.3.1
>      newlib   1.11.0
>      insight  5.3
> 
> Now i made a new one with
>      binutils 2.18
>      gcc    4.2.1
>      newlib    1.15.0
>      insight    6.6
> 
> I can build ecos without apparent problems (i'm working with a simple 
> eb40a target).
> 
> Then, when i try to make a simple application (or if i try to make ecos 
> tests), it's when my problems appears.
> 
> I get lots of errors like this:
> 
> work/eCos/lib/eb40a/rom/eb40a_rom_sin_net_v00.20_install/lib/extras.o: 
> In function `__static_initialization_and_destruction_0':
> /opt/ecos-snap-2007-09-09/packages/io/fileio/current/src/misc.cxx:105: 
> undefined reference to `__cxa_atexit'
> 
> /opt/ecos-snap-2007-09-09/packages/io/fileio/current/src/misc.cxx:125: 
> undefined reference to `__cxa_atexit'
> /opt/ecos-snap-2007-09-09/packages/io/fileio/current/src/misc.cxx:532: 
> undefined reference to `__dso_handle'
> 
> Could someone help me?
> 
> Thanks
>      Santiago Lafon

The libraries you are using may not be compatible.  Not long ago the
latest version of gcc on x86 would not work (for me) with the latest
version of binutils.  Check the installation notes for gcc.

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list