[ECOS] Re: Building error on CVS checkout sources

Andrew Lunn andrew@lunn.ch
Fri Sep 14 08:22:00 GMT 2007


> I usesd Template for Target "Hitach SE77x9 board" and "old_net".
> I tried "net" Template too but resulted into the same error.

...

> `/ecos-c/cygwin/home/LINK/ecoscvs-old_net/untitled1_build'
> /opt/ecoscvs/ecos/packages/net/common/current/src/dhcp_prot.c:1375: 
> internal error: Segmentation fault
> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

lunn@londo:~/eCos/work$ rm -fr *
lunn@londo:~/eCos/work$ ecosconfig new se77x9 net
U CYGPKG_HAL_SH_7709A, new inferred value 0
U CYGPKG_HAL_SH_7709S, new inferred value 1
U CYGPRI_HAL_SH_SH77X9_SUPERIO, new inferred value 1
U CYGHWR_HAL_SH_IRQ_USE_IRQLVL, new inferred value 1
U CYGBLD_ISO_STRUCTTIMEVAL_HEADER, new inferred value <cyg/posix/sys/time.h>
U CYGBLD_ISO_FNMATCH_HEADER, new inferred value <cyg/fileio/fnmatch.h>
lunn@londo:~/eCos/work$ ecosconfig tree
lunn@londo:~/eCos/work$ make -s
headers finished
build finished

So it builds for me.

What version of gcc are you using? I have:

lunn@londo:~/eCos/work$ sh-elf-gcc -v
Reading specs from /opt/ecos/gnutools/sh-elf/bin/../lib/gcc-lib/sh-elf/3.2.1/specs
Configured with: /home/demonweb/tools/ecos-gnutools-v1.4/r2/sh-elf/x86_linux_lsb1_3/tar_bz2/source/gcc-3.2.1/configure --target=sh-elf --prefix=/home/demonweb/tools/ecos-gnutools-v1.4/r2/sh-elf/x86_linux_lsb1_3/tar_bz2/opt/ecos/gnutools/sh-elf --enable-languages=c,c++ --with-gnu-as --with-gnu-ld --with-newlib --with-gxx-include-dir=/home/demonweb/tools/ecos-gnutools-v1.4/r2/sh-elf/x86_linux_lsb1_3/tar_bz2/opt/ecos/gnutools/sh-elf/sh-elf/include
Thread model: single
gcc version 3.2.1

    Andrew

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list