[ECOS] Sockets getting full..

James Hunter jhunter@aptx.com
Thu Jun 28 15:12:00 GMT 2007


> -----Original Message-----
> From: Andrew Lunn [mailto:andrew@lunn.ch] 
> Sent: 27 June 2007 23:45
> To: James Hunter
> Cc: ecos-discuss@ecos.sourceware.org
> Subject: Re: [ECOS] Sockets getting full..
> 
> On Wed, Jun 27, 2007 at 11:25:32AM +0100, James Hunter wrote:
> > Hi,
> > 
> > We are using a PowerQuicc III (MPC8541@677Mhz - so plenty of grunt) 
> > which is tasked with sending and receiving data over a UDP 
> connection.
> > The test application is only receiving data from another 
> external UDP 
> > transmitter.
> > 
> > What we are seeing is almost immediately the socket is 
> filling up with 
> > data as if your application is not reading the data back 
> quickly enough.
> > 
> > 
> > This test application spins on a Select() waiting to get 
> packets, its 
> > executing around ~10k times per second so fast enough to catch any 
> > packets - we do sleep at the end of this loop.
> > 
> > The sending unit sends around 700 packets per second, however we 
> > receive only around 120 (going on the results returned by 
> Select function).
> > However the packets received are in order (using a sequence 
> number) so 
> > nothing is dropped, they just appear to fall out of Select really 
> > really slow (we are aiming for a lot more than 700 packets 
> per second 
> > from the
> > HW)
> 
> I think we need to see the code in order to understand this....
> 
>   Andrew
> 
Hi,

We resolved the issue, appears to be some legacy i2c code that was
causing us problems.

Thanks,

James.

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list