[ECOS] how to check my modifications to the kernel without a board?

xiaolu zhao deerxiaolu@gmail.com
Wed Jun 27 09:48:00 GMT 2007


Because my command-line ecosconfig does not work, I tried to use
graphic configtool to try the tests suggested by andrew.

But I met some problems:
1. If I want to run the eCos on the vmware, I think I need a .bin file
to generate the floppy image and load to the vmware. When I use
redboot, I know there is a option in the config file to choose
("Redboot ROM monitor/Redboot HAL options/Build RedBoot binary image")
and I can get a bin file in the generated install folder. But without
redbboot, I do not know how to generate the bin file?

2. I want to try the tests cases using configtool. but it seems the
hardware platform should be connected, does it? Does that mean if I
want to do the test, I should run the vmware at the same time?

Would you like to give me some advice about these problems? Thank you so much!



On 6/14/07, Andrew Lunn <andrew@lunn.ch> wrote:
> On Thu, Jun 14, 2007 at 05:14:18PM +0200, xiaolu zhao wrote:
> > Hi, I met a big problem, would you like to give me some advices?
> >
> > I did some modifications to the ecos Kernel code(like in sched.cxx,
> > thread.hxx etc.). But I have no a real hardware board. So I want to
> > use VMware as a virtual machine to see the results.Is it possible?
>
> Should be, but i have never done it myself. However, i would actually
> recommend using the synthetic target on Linux.
>
> > I tried the redbbot on the Vmware and the "hello.c" example works. But
> > after I modified the kernel code and rebuild the ecos using the
> > configtool, it did not give any compilation complaints. I know it is
> > impossible, there should be a lot of errors in the code. Does Redbbot
> > have nothing to do with the ecos kernel files?
>
> Redboot does not use the kernel.
>
> > If the redboot has nothing to do with the kernels, how can I check my
> > modificaiton to the kernel files with VMare?
>
> I would suggest you use the kernel test cases. These are good tests to
> see if your changes have broken anything.
>
> Try doing:
>
> ecosconfig new pc_rltk8139
> edit ecos.ecc and change CYG_HAL_STARTUP to floppy
> ecosconfig tree
> make -s tests
>
> Once you have fixed all the compiler error you can run the test cases
> in install/tests/kernel/current.
>
>   Andrew
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list