[ECOS] Fwd: Re: [ECOS] building ecos using configuration tools under windows - invalid data base

Paul D. DeRocco pderocco@ix.netcom.com
Mon Jun 18 13:20:00 GMT 2007


> From: spreet singh
> 
> > Thanks for the response.
> > I tried the suggestion and it stll gives the same
> > response:
> > " Error opening eCos repository - Invalid package
> > database"
> > and other message is:
> > ecos.db:error - couldnt read file 
> "/ecoscvs/ecos/packages/ecos.db" no 
> > such file or directory.

I find that it works for me if I run the tool from the bash shell, instead
of directly from Windows, e.g.:

	/opt/ecos/configtool-060710.exe &

It appears that when invoked from Windows, it's not finding out that Cygwin
"/" is mounted at "C:\Cygwin". Once you're in a bash shell, that mount seems
to work. I've checked on my system, and my mounts are all under
HKEY_LOCAL_MACHINE, not HKEY_CURRENT_USER, so I can't imagine what the
problem could be, but that's my workaround.

-- 

Ciao,               Paul D. DeRocco
Paul                mailto:pderocco@ix.netcom.com 


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list