[ECOS] ECOS: Free BSD - Default gateway entry , duplicate ARP//llinfo entries -

Alok Singh aloks@broadcom.com
Sun Jul 29 01:49:00 GMT 2007


Hi,
I'm using latest cvs code. This is the same issue I mentioned earlier,
where I'm not able to access the box from a different subnet. I debugged
the issue further, and I see two llinfo entries corresponding to the
default gateway. One is created as soon as the default routing entry is
configured.  This has mac address as "0".  Default gateway points to
this entry. When I ping from other network, then arp of gateway is
resolved. And this creates another entry in the routing table. But
default gateway routing entry is still pointing to the old one that ahs
mac address as 0. Hence for every ping, I see an ARP request going out
of the box. My GW is 10.240.3.1. I'm providing the ROUTE TREE dump
below. Please have a look. Look for key field in the the dump to see the
duplication. I've verified that for IP addresses other than G/W, only
one ARP entry is present( 10.240.3.136). MY box IP address
is:10.240.3.156. I've enabled the debugs in icmp_input, and I can see
that the imcp echo reply is being sent out to IP in different subnet- 
icmp_input from 10.240.10.236 to 10.240.3.156, len 40
icmp_input, type 8 code 0
icmp_send dst 10.240.10.236 src 10.240.3.156
*********************************************
Route tree for AF_INET
rtentry=0x805f8d10 flags=0x10003 refcnt=0 use=7 expire=0
 key=[16,2,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
 mask=[]
 gw=[16,2,0,0,10,240,3,1,128,60,139,80,128,33,93,72]
 ifp=0x805612d4 (dtl) ifa=0x805f8f30
  ifa_addr=[16,2,0,0,10,240,3,156,0,0,0,0,0,0,0,0]
  ifa_dsta=[16,2,0,0,10,240,3,255,0,0,0,0,0,0,0,0]
  ifa_mask=[7,0,0,0,255,255,255]
  flags=0x101, refcnt=5, metric=0
 genmask=[NULL] gwroute=0x805f8c40 llinfo=0x00000000
------------
rtentry=0x805f8e90 flags=0x101 refcnt=3 use=0 expire=30
 key=[16,2,0,0,10,240,3,0,0,0,0,0,0,0,0,0]
 mask=[7,255,255,255,255,255,255]
gw=[54,18,0,1,6,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
 ifp=0x805612d4 (dtl) ifa=0x805f8f30
  ifa_addr=[16,2,0,0,10,240,3,156,0,0,0,0,0,0,0,0]
  ifa_dsta=[16,2,0,0,10,240,3,255,0,0,0,0,0,0,0,0]
  ifa_mask=[7,0,0,0,255,255,255]=
  flags=0x101, refcnt=5, metric=0
 genmask=[NULL] gwroute=0x00000000 llinfo=0x00000000
--------------
rtentry=0x805f89c0 flags=0x20405 refcnt=0 use=0 expire=4029
 key=[16,2,0,0,10,240,3,1,0,0,0,0,0,0,0,0]
 mask=[NULL]
gw=[54,18,0,1,6,0,6,0,0,15,181,52,144,196,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
 ifp=0x805612d4 (dtl) ifa=0x805f8f30
  ifa_addr=[16,2,0,0,10,240,3,156,0,0,0,0,0,0,0,0]
  ifa_dsta=[16,2,0,0,10,240,3,255,0,0,0,0,0,0,0,0]
  ifa_mask=[7,0,0,0,255,255,255]
  flags=0x101, refcnt=5, metric=0
 genmask=[NULL] gwroute=0x00000000 llinfo=0x805f8940
  la_rt=0x805f89c0 la_hold=0x00000000, la_asked=0x0
----------------------
rtentry=0x805f8c40 flags=0x2040d refcnt=1 use=0 expire=2999
 key=[16,2,0,0,10,240,3,1,128,60,139,80,128,33,93,72]
 mask=[NULL]
gw=[54,18,0,1,6,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
 ifp=0x805612d4 (dtl) ifa=0x805f8f30
  ifa_addr=[16,2,0,0,10,240,3,156,0,0,0,0,0,0,0,0]
  ifa_dsta=[16,2,0,0,10,240,3,255,0,0,0,0,0,0,0,0]
  ifa_mask=[7,0,0,0,255,255,255]
  flags=0x101, refcnt=5, metric=0
 genmask=[NULL] gwroute=0x00000000 llinfo=0x805f8ba0
  la_rt=0x805f8c40 la_hold=0x80605e80, la_asked=0x0
------------
rtentry=0x805f8ae0 flags=0x20405 refcnt=0 use=5 expire=1233
 key=[16,2,0,0,10,240,3,136,0,0,0,0,0,0,0,0]
 mask=[NULL]
gw=[54,18,0,1,6,0,6,0,0,20,42,44,68,86,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
 ifp=0x805612d4 (dtl) ifa=0x805f8f30
  ifa_addr=[16,2,0,0,10,240,3,156,0,0,0,0,0,0,0,0]
  ifa_dsta=[16,2,0,0,10,240,3,255,0,0,0,0,0,0,0,0]
  ifa_mask=[7,0,0,0,255,255,255]
  flags=0x101, refcnt=5, metric=0
 genmask=[NULL] gwroute=0x00000000 llinfo=0x805f8a60
  la_rt=0x805f8ae0 la_hold=0x00000000, la_asked=0x0



I'm getting the address/GW from DHCP server. My routing table after
configuring the IP address and GW is provided below. 
Routing tables

Destination     Gateway         Mask            Flags    Interface

0.0.0.0         10.240.3.1      0.0.0.0         UG       eth0
10.240.3.0      10.240.3.0      255.255.255.0   U        eth0     

127.0.0.0       127.0.0.1       255.0.0.0       UG       lo0      

127.0.0.1       127.0.0.1                       UH       lo0      

Interface statistics

Eth0    IP: 10.240.3.156, Broadcast: 10.240.3.255, Netmask:
255.255.255.0

        UP BROADCAST RUNNING MULTICAST MTU: 1500, Metric: 0

        Rx - Packets: 100, Bytes: 19483, Tx - Packets: 12, Bytes: 720

lo0     IP: 127.0.0.1, Broadcast: 127.0.0.1, Netmask: 255.0.0.0

        UP LOOPBACK RUNNING MULTICAST MTU: 16384, Metric: 0

        Rx - Packets: 0, Bytes: 0, Tx - Packets: 0, Bytes:




regards,
Alok


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list