[ECOS] How to enable diag_printf at Redboot

Tales Toledo toledo.tales@gmail.com
Mon Jul 9 15:45:00 GMT 2007


On 7/6/07, Sergei Gavrikov <w3sg@softhome.net> wrote:
> On Fri, Jul 06, 2007 at 04:37:47PM -0300, Tales Toledo wrote:
> > On 7/6/07, Sergei Gavrikov <w3sg@softhome.net> wrote:
> > >On Fri, Jul 06, 2007 at 03:32:01PM -0300, Tales Toledo wrote:
> > >> Hi,
> > >>
> > >> I would like to enable all diag_printf messages at Redboot.
> > >> How can I do this?
> > >> Which cdl option should I have to enable to make it works?
> > >
> > >There are a lot of debug messages in RedBoot. That depends on packages
> > >are used to build RedBoot (RedBoot is a closely target related stuff).
> > >You can see that, U.T.S.L.
> > >
> > >find $ECOS_REPOSITORY/redboot/current/src | xargs grep DEBUG
> > >
> > >You can meet ZM_DEBUG, DEBUG_TCP, etc., etc., etc.
> > >
> > >but it seems, that more suitable way is to look at any CYGDBG_REDBOOT_*
> > >options in your `ecos.ecc' is prepared to build RedBoot
> > >
> >
> > I enable CYGDBG_REDBOOT_NET_DEBUG that is the most important for me
> > right now. Unfortunately  I am having some problems with flash
> > configuration at boot that override it with 0.
> > I can't see any messages until now...
>
> Ah, I did pass your vis-a-vis dialog with Gary. I'm seeing now what is
> your issue. That is a flash config issue, isn't that? I look at some
> RedBoot options/semaphores and found this one
>
> cdl_option CYGSEM_REDBOOT_FLASH_CONFIG_READONLY_FALLBACK {user_value 1};

Yes, I believe it could be a flash config problem. I have tried it but
with no success. I am still having the same behavior. The flash was
written (I'm sure because i can dump and see the ip address
server/mask/gateway) but seems that Redboot don't    take this
configuration from flash at boot up.

>
> Perhaps, some fail(s) protected itself by such a way? But, you told that
> fconfig copy in RAM is good. Did you tried to change the default flash
> config block number (cdl_option CYGNUM_REDBOOT_FLASH_CONFIG_BLOCK) ?

I also change it. Should I see the differences at fis list command? I
choose -4 as example and the Redboot config remains at 0x407FF000. It
should be at 0x407FA000. Did i understand the cdl_option right?

>
> Execuse me that my useless suggest about DEBUG* options. I would play
> with a set of the CYG*REDBOOT*FLASH*CONFIG defaults at the end: editing
> `ecos.ecc' and re-building RedBoot. But that can take your whole weekend.
>
Any help is welcome. No excuses, only thanks.

> Regards,
>
> Sergei
>
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list