[ECOS] eCos invalidating JTAG on ARM architecture ?

Paul D. DeRocco pderocco@ix.netcom.com
Thu Jul 5 16:04:00 GMT 2007


> From: Alexandre
> 
> After I upload my eCos code to my board via JTAG (code which 
> is fully functioning by the way), I can't by any mean reach 
> it again via JTAG. OpenOCD just says it can't communicate 
> with my board. Seems like eCos just disable my JTAG. The only 
> way I can access my micro controller again is by UART, 
> erasing the flash using ISP, and then reflashing it by JTAG 
> works anew. So it works, but I can't debug the thing.

In general, JTAG debugging is best for getting your startup code working.
Once you've done that, you're better off debugging over serial, or if you
have it, Ethernet. As far as I know, OpenOCD doesn't have any particular
support for eCos threads (correct me if I'm wrong). To do that, the debugger
must be able to execute some eCos code, invoked through the virtual vector
table. I don't think any JTAG debugger can do that.

I suggest configuring a full-featured version of Redboot, and getting that
into the flash. Then debug your application in RAM over serial or Ethernet.
You can ultimately get Redboot to boot your application from an image stored
in flash.

-- 

Ciao,               Paul D. DeRocco
Paul                mailto:pderocco@ix.netcom.com 


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list