[ECOS] ecos application problem

albert prasetyo prasetyoalbert@gmail.com
Mon Aug 27 05:53:00 GMT 2007


Hi all;

>
> Try to import this
>
> cat <<_EOF | ecosconfig import /dev/stdin
> cdl_option CYGSEM_HAL_USE_ROM_MONITOR {inferred_value 0 Generic};
> cdl_option CYGSEM_HAL_DIAG_MANGLER {user_value None};
> _EOF
>
> before the build the eCos stuff

I have applied above, but still can't get the expected result. The
output of redboot
become as follows:

RedBoot> load -m y
CCEntry point: 0x21000040, address range: 0x21000000-0x210082b0
xyzModem - CRC mode, 3(SOH)/98(STX)/0(CAN) packets, 4 retries
RedBoot> go

After go command was executed, the redboot seems to 'hang' . I think redboot
expected some input from user. I tried to input '+' but nothing happened.

I read from other threads and conclude that it is possible to run
application by disabling debug channel. I intend to do it by disable
'debug serial port'
(i.e. CYGNUM_HAL_VIRTUAL_VECTOR_DEBUG_CHANNEL) but cannot do it
(cannot find CYGPRI_HAL_VIRTUAL_VECTOR_DEBUG_CHANNEL_CONFIGURABLE).
Is it the right thing to do?

By the way I run my redboot on RAM mode, maybe it's the cause the
update can't work. When I try to use redboot in ROM mode, even the
application cannot be downloaded at all. (as described by Henry Wong
in this link :
http://ecos.sourceware.org/ml/ecos-discuss/2006-05/msg00047.html )
Thank you for your attention.

Regards;
Albert P

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list