[ECOS] eCOS on MPC5567 - printf()

Alexander Bochem abochem@googlemail.com
Thu Aug 9 08:22:00 GMT 2007


Hi @all,

I have several problems using eCOS on a developmentboard with an
PPC5567. (Pre Qualification of MPC5567)
I am developing under WinXP using Cygwin and the eCOS Configuration
Tool 2. For flashing and debugging I have "TRACE32 ICE PPC Ethernet on
Host".
Till now I managed to compile a simple program and load it into ROM.
It can only send "Hello World" via serial port to my host using
cyg_io_write().

When I use the printf() method it causes the error "entry near offset"
during the flash procedure. Using Dump to get a picture of the memory
where it occurs I can only see lots of "?????".
If I remove printf() from my sample programm, it is running well.
I also tried to write my own printf() wich uses the method
cyg_io_write() but this can't be the true way to working with eCOS.
In my eCOS build I changed standard IO to /dev/ser1 but that also
seems not to work.

Maybe my compiler for the powerpc-eabispe architecture is to old? Or
my eCOS configuration is incorrect?

If someone had already worked with eCOS on MPC5567 he or she can send
me the eCOS configuration file?

Thanks for your time.
   Alex

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list