[ECOS] Re: context.S problem

Jonathan Larmour jifl@eCosCentric.com
Mon Sep 11 14:08:00 GMT 2006


Wendell Liu wrote:
> Thanks, Jonathan.
> 
> I didn't put all the flags in the email.

Then please do.

> Yes, I read almost all the manuals
> and the Anthony J. Massa's eCos book. The build should be quite straight
> forward. My issue is probably related to my computer setting/environments
> etc. Could you give me some hints here?

The line in question in context.S does not appear to have a relocation on 
it *unless* CYGARC_JMPBUF_SP has somehow not been defined. Check the 
contents of install/include/cyg/hal/sh_offsets.inc. And try a clean build 
from an empty tree.

Jifl

> -----Original Message-----
> From: Jonathan Larmour [mailto:jifl@ecoscentric.com] 
> Sent: September 10, 2006 4:54 PM
> To: Wendell Liu
> Cc: 'mirko massignani'; 'eCos discussion'
> Subject: Re: context.S problem
> 
> Wendell Liu wrote:
>>  
>> Hello, Andrew and other eCos experts,
>>
>> I just started using eCos with SH4 for my next project, and I try to 
>> build eCos image. On my machine, I always encountered the following
> errors:
>> sh-elf-gcc -c -I/... src/hal_sh_arch_context.o 
>> /cygdrive/c/cygwin/opt/ecos/ecos/packages/hal/sh/arch/current/src/cont
>> ext.S
>>
>>
> /cygdrive/c/cygwin/opt/ecos/ecos/packages/hal/sh/arch/current/src/context.S:
>> Assembler messages:
>>
> /cygdrive/c/cygwin/opt/ecos/ecos/packages/hal/sh/arch/current/src/context.S:
>> 257:
>> Error: Cannot represent relocation type BFD_RELOC_SH_IMM4BY4
> 
> I don't see the correct compiler flags there. How are you trying to build
> eCos? Have you read the user manual?
> 
> Jifl


-- 
eCosCentric    http://www.eCosCentric.com/    The eCos and RedBoot experts
------["The best things in life aren't things."]------      Opinions==mine

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list