[ECOS] Re: unable to execute linux kernel with Redboot

Amitesh Singh singh.amitesh@gmail.com
Tue Sep 5 13:51:00 GMT 2006

On 9/5/06, Claudio Scordino <cloud.of.andor@gmail.com> wrote:
> On Monday 04 September 2006 13:14, Amitesh Singh wrote:
> > Hi
> >  I am assuming that ur RootFS lives in RAM.
> > RedBoot>load -r -v -b 0x01600000
> > RedBot> load -r -v -b 0x00800000 ramdisk.gz
> > RedBoot> exec -b 0x01600000 -l 0x10000 -c "console=ttyS0,115200
> > root=/dev/ram0 initrd=0x00800000,8M mem=32M@0x00000000"
> >
> > Note: 8M is ur RamDisk size and 32M is ur SD RAM size.
> >
> > Let me know if it works.
> It worked and I  was able to succcesfully run a big-endian kernel :) Many
> thanks.
> I also tried to execute a little-endian kernel on the target, using the
> "-x" option of the exec command, but it didn't work.
> Many thanks,
>                      Claudio
Cool,its good to know that it worked for Big-endian kernel. :)

For little endian kernel.

use Swab to byteswap the image before executing the kernel.
1)load the kernel
2)byteswap the kernel using swab command
3)execute it using exec command with -x switch.

It should work.

Good Luck

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list