[ECOS] cvs fails when -d is used on checkout

Grant Mills gmills@ucsd.edu
Sat Mar 11 17:13:00 GMT 2006


On 3/11/06, Andrew Lunn <andrew@lunn.ch> wrote:
> On Fri, Mar 10, 2006 at 06:33:12PM -0800, Grant Mills wrote:
> > Anybody,
> >     Quick question, but can anybody think of a reason that
> >         "cvs -z3 -d <appro' cvs root> co -d
> > other_than_standard_ecos_directory -P ecos"
> > would fail?  I used the following command with out the -d option and
> > it worked fine.  Any thoughts?
> >
> > Here's the output:
> >
> > [gmills :139]% cvs -q -z3 -d
> > :pserver:anoncvs@ecos.sourceware.org:/cvs/ecos co -r flash_v2 -d
> > ecos_flash_v2-1 -P ecos
> > cvs checkout: warning: new-born ecos_flash_v2-1/COPYING has disappeared
> > cvs checkout: warning: new-born ecos_flash_v2-1/ChangeLog has disappeared
> > cvs checkout: warning: new-born ecos_flash_v2-1/Makefile.am has disappeared
>
> The CVS documentation says:
>
> -d DIR
>     Create a directory called DIR for the working files, instead of
>     using the module name.  In general, using this flag is equivalent
>     to using `mkdir DIR; cd DIR' followed by the checkout command
>     without the `-d' flag.
>
> So why not use the mkdir cd option instread.
>
>        Andrew
>
>

I've been using:
1. cvs co
2. mv ecos desired-dir-name

But that wasn't my question.  I was wondering if the ecos repository
had some checkout scripts that was causing this behavior.  Any
thoughts?

--
Grant Mills
gmills@ucsd.edu

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list