[ECOS] processor hangs at 'hal_mon_init'

bob.koninckx@o-3s.com bob.koninckx@o-3s.com
Wed Jun 28 07:27:00 GMT 2006


>-----Original Message-----
>From: Rohit Pandita [mailto:pandi008@umn.edu]
>Sent: Tuesday, June 27, 2006 05:36 PM
>To: 'Gary Thomas'
>Cc: ecos-discuss@sourceware.org
>Subject: Re: [ECOS] processor hangs at 'hal_mon_init'
>
>Gary Thomas wrote:
>> Rohit Pandita wrote:
>>> Hi all,
>>>
>>> While trying to singlestep through RedBoot in ROM (platform
>>> PhyCore555), processor hangs at 'hal_mon_init' routine. Any clues
>>> would be appreciated.
>>
>> What are you using to single step the code?  That macro fiddles with
>> the MSR (Machine State Register) and it might do something that confuses
>> your debug environment.
>>
>
>Im using P&E Micro's BDM interface(usb-ml-ppcbdm) and debugger(icdppcz).
>Thanks.

Most BDMs exploit the MPC555 hardware to step instruction by instruction, so I doubt that could be the cause of your problem. It is more likely that something is wrong with your configuration. Which startup type do you use (ROM or RAM), is CYGSEM_HAL_USE_ROM_MONITOR defined ? Do you have any idea where exactly in hal_mon_init things go wrong ? What's the contents of the different processor registers right before it locks up ? Does it actually lock up, or is a processor exception raised (e.g. illegal instruction or memory protection) that does not bring the processor back into BDM mode ?

Bob

>
>--
>Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
>and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
>
>



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list