AW: [ECOS] [OT] minicom upload missing files

Sergei Gavrikov w3sg@SoftHome.net
Thu Jul 20 09:51:00 GMT 2006



On Thu, 20 Jul 2006, Neundorf, Alexander wrote:

> Hi Patrick,
>
>> Von: ecos-discuss-owner@ecos.sourceware.org
>> [mailto:ecos-discuss-owner@ecos.sourceware.org]Im Auftrag von Doyle,
>> Patrick
>>
>> Hi folks!
>> This is definitely off-topic for eCos discussions, but I
>> imagine that there are folks on this list who use minicom on a regular basis.
>> Some of them may even use minicom on a recent RedHat/Fedora based system.  So...
>>
>> When I use minicom to send binary images to my target, and I enter "C-A" "s"
>> to send the file, the directory listing does not include all of the files in
>> the named directory.  I've seen this for some time on other folks
>> (RedHat/Fedora) machines, but it hasn't bothered me because, well, it worked
>> fine on my (SuSE) machine.  But I recently switched to FC5, and now it
>> bothers me... :-)
>>
>> Has anybody else (outside of DTC) seen this?  Has anybody
>> figured out the root cause and fixed it?
>
> <self_advertising>
>
> Just try cutecom ( http://cutecom.sf.net ), it should do (almost) everything minicom does. If there's something missing, send a feature request to the developer ;-)
>
> </self_advertising>
>

I prefer to use a `runscript' with minicom. Sometimes, files are located
so far from minicom upload directory. Usually, those are the eCos tests.

I add a simple rule to Makefile:

load: ${DST}
 	rbld ${DST}

and then do `make load'

Here is my `rbld' (redboot load) shell script to upload a code with
RedBoot xyzmodem. For details: man runscript.

usage: rbld <filename> ?-b?

Sergei
-------------- next part --------------
#! /bin/sh
#
# usage: rbld <filename> ?-b?

MINIRC=dfl		# set a minicom config name
SCRIPT=/tmp/runscript 	# read man runscript
TIMOUT=300		# max. 5 min to upload
BINARY=0		# default format is elf, or s-rec
			# use -b option for binary format

test -z ${1} && exit 1	# quite die

test ".${2}" == ".-b" && BINARY=1

echo -n 'Press [Enter] when target is reset, ^C to abort load '; read

# read man runscript
cat > ${SCRIPT} << __eof
timeout ${TIMOUT}
rbprompt:
        send "\003\c"
        expect {
            "RedBoot>" goto start
            timeout 1 goto rbprompt
        }
start:
        send "lo -m y\c"
	if ${BINARY} > 0 send " -r -b %{FREEMEMLO}"
	send ""
        ! sz  -vv ${1}
__eof

minicom ${MINIRC} -S ${SCRIPT}
-------------- next part --------------
-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss


More information about the Ecos-discuss mailing list