[ECOS] Re: Re: Re: Re: wget problem for the Proxy

Fischetti Antonio antonio.fischetti@gmail.com
Fri Jul 7 15:31:00 GMT 2006


Ooooops! My mistake. It was due to the lack of free space on my partition.
I changed partition from C: to E: and installed again Cygwin, then
sh ecos-install.tcl
worked fine.

I executed the command

. /opt/ecos/ecosenv.sh

Then when I run configtool.exe it asks for valid repository tree.
I specify the root of eCos repository tree:

E:\cygwin\opt\ecos\ecos-2.0

which is the directory that contains: acsupport, doc, examples, tools.

The window appears but a lot of error messages say something like
"This package does not have any valid version subdirectories" or such.

After that the window is closed.

Is there any setting I should do with ecosconfig.exe ?


Thank you,
Antonio.


On 7/7/06, Alex Schuilenburg <alexs@ecoscentric.com> wrote:
> Fischetti Antonio wrote:
> > Hi, it seems it improved a bit.
> > My 'wgetrc' file now looks like (I replaced the real Proxy name, IP
> > and port with
> > <proxy_name>, <IP_proxy_addr>, and <port_number>)
> >
> > ______________
> >
> > http_proxy = <proxy_name>:<port_number>
> > ftp_proxy = <proxy_name>:<port_number>
> > use_proxy = on
> > ______________
> >
> >
> > This is what gets displayed on my Cygwin window
> > ______________
> > $ wget --passive-ftp ftp://ecos.sourceware.org/pub/ecos/ecos-install.tcl
> > --10:05:41--  ftp://ecos.sourceware.org/pub/ecos/ecos-install.tcl
> >           => `ecos-install.tcl.1'
> > Resolving <proxy_name>... <IP_proxy_addr>
> > Connecting to <proxy_name>|<IP_proxy_addr>|:<port_number>... connected.
> > Proxy request sent, awaiting response... 407 Proxy Authentication
> > Required
> > 10:05:41 ERROR 407: Proxy Authentication Required.
> > ______________
> >
> > And it stops.
> > When I usually connect to the proxy (i.e. to surf the web) I provide a
> > username and password. How can I add Username/password to 'wgetrc'? Or
> > is there anything else to be done?
> Also add to .wgetrc
>
> proxy_user =
>
> proxy_passwd =
>
>
> -- Alex
>
> Managing Director / CEO                              eCosCentric Limited
> http://www.ecoscentric.com/                 The eCos and RedBoot experts
>
>
> >
> >
> > Thanx alot,
> > Antonio.
> >
> > On 7/6/06, Grant Mills <gmills@ucsd.edu> wrote:
> >> Find and edit .wgetrc
> >>
> >> Set the proxies.  There is one for http and one for ftp:
> >>
> >> http_proxy =
> >> ftp_proxy =
> >>
> >> Don't forget to enable the proxies either:
> >>
> >> use_proxy = on
> >>
> >> This may be of little use if your ftp proxy server does not conform to
> >> what wget supports.  NcFTP and FileZilla both have much broader
> >> support for proxy servers.
> >>
> >> On 7/6/06, Fischetti Antonio <antonio.fischetti@gmail.com> wrote:
> >> > I'm can't download with
> >> > wget --passive-ftp ftp://ecos.sourceware.org/pub/ecos/ecos-install.tcl
> >> >
> >> > It says "Unresolved Host".
> >> > I am under a proxy.
> >> > Do I need a special version of wget. Sort of 'socks' style?
> >> >
> >> > Thanx.
> >> >
> >> > --
> >> > Before posting, please read the FAQ:
> >> http://ecos.sourceware.org/fom/ecos
> >> > and search the list archive:
> >> http://ecos.sourceware.org/ml/ecos-discuss
> >> >
> >> >
> >>
> >>
> >> --
> >> Grant Mills
> >> gmills@ucsd.edu
> >>
> >
>
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list