[ECOS] LPC-H2294 redboot....

Gary Thomas gary@mlbassoc.com
Sun Jul 2 13:55:00 GMT 2006


Marcin Chrusciel wrote:
> Hi,
> 
> I tried to build redboot image for LPC-H2294 board uusing a
> http://sourceware.org/ml/ecos-discuss/2006-02/msg00031/lpch2294-1.0.ep
> patch and I get following error:
> 
> arm-elf-gcc -c
> -I/ecos-c/CIT/Projects/Internal/ARM7/ecos/H2294/LPCH2294_redboot_install
> /include -I/tmp/ecos/packages/hal/arm/arch/current
> -I/tmp/ecos/packages/hal/arm/arch/current/src
> -I/tmp/ecos/packages/hal/arm/arch/current/tests -I.
> -I/tmp/ecos/packages/hal/arm/arch/current/src/ -finline-limit=7000
> -mthumb-interwork -mcpu=arm7tdmi -Wall -Wpointer-arith
> -Wstrict-prototypes -Winline -Wundef  -g -O2 -ffunction-sections
> -fdata-sections  -fno-exceptions   -Wp,-MD,src/redboot_linux_exec.tmp -o
> src/hal_arm_arch_redboot_linux_exec.o
> /tmp/ecos/packages/hal/arm/arch/current/src/redboot_linux_exec.c
> make[1]: Leaving directory
> `/ecos-c/CIT/Projects/Internal/ARM7/ecos/H2294/LPCH2294_redboot_build/ha
> l/arm/arch/current'
> /tmp/ecos/packages/hal/arm/arch/current/src/redboot_linux_exec.c:80:3:
> error: #error 
> make: Leaving directory
> `/ecos-c/CIT/Projects/Internal/ARM7/ecos/H2294/LPCH2294_redboot_build'
> make[1]: *** [src/redboot_linux_exec.o.d] Error 1
> make: *** [build] Error 2
> 
> I'm able to build ecos itself. I only have problem with redboot
> compilation. Thanx for any help already!
>

Try adding this line to your target/platform CDL file:
   requires { !CYGBLD_BUILD_REDBOOT_WITH_EXEC }

Then rerun 'ecosconfig tree' and 'make'

-- 
------------------------------------------------------------
Gary Thomas                 |  Consulting for the
MLB Associates              |    Embedded world
------------------------------------------------------------

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list