[ECOS] Problem with accept() on i386 pc.

Gary Thomas gary@mlbassoc.com
Thu Apr 20 23:02:00 GMT 2006


On Thu, 2006-04-20 at 15:30 -0700, Patrick O'Grady wrote:
> Hi, all--
> 
> Curious if anyone else has seen this problem, or if I'm just doing something 
> wrong.  If I compile the following program on cygwin, then it works as 
> expected: I can 'telnet localhost 7227' and see my server there.  However, 
> if I compile this program and run it on my i386 pc with an i82559 ethernet 
> adapter, it doesn't work.  My target system is at IP address 10.4.0.73, and 
> I can ping that with no problems.  But if I 'telnet 10.4.0.73 7227', I get 
> response SYN response packets with RST--implying that the port isn't 
> listening.  My target is configured using 'ecosconfig new pc net' with eCos 
> from CVS as of today (4/20).  I've not tried this program on eCos before; 
> but if I undefine ECOS_MODE, then it compiles and works under Cygwin as 
> expected.  Thanks for your input!

This looks very similar to the standard test "server_test".  Have you
tried running it on your hardware?

-- 
------------------------------------------------------------
Gary Thomas                 |  Consulting for the
MLB Associates              |    Embedded world
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list