[ECOS] Using a different toolchain

John R. Dunning jrd@jrd.org
Tue Apr 4 14:12:00 GMT 2006


    From: Andrew Lunn <andrew@lunn.ch>
    Date: Tue, 4 Apr 2006 15:16:47 +0200
    
    
    You want to change CYGBLD_GLOBAL_COMMAND_PREFIX

Ok, tnx.
    
    
    What is wrong with the linker script eCos generates? Since you are
    still using gcc and i assume you are still using binutils, 

Yes.
							       i would of
    thought target.ld would work.
    
Well, I dunno; I may just be not looking at the right thing.  I'm
trying to use what amounts to a 64-bit mips toolchain (it's a mips
instruction set, with some extra hacks added to it for custom
hardware) so I started with the 32-bit stuff, got that to build ok,
then tried swapping in the 64-bit stuff.  The 64-bit linker barfed on
the references to elf32-littlemips in target.ld, so I tried changing
them to what I thought were equivalent 64-bit things, but that didn't
work either.  I tried using the linker script that I use for other
(non-ecos) binaries on this platform, and that said it built an
executable, but when I objdump it, there's nothing in .text.

Perhaps I need to go off and read up on linker scripts, because my
non-ecos one bears approximately zero resemblance to the ecos one, and
I can intuit only vaguely what either one of them are doing :-{


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list