[ECOS] Newbie question: eCOS and Redboot for AT91SAM7S-EK

Wayne Liu Wayne.Liu@prostorsystems.com
Mon Apr 3 16:50:00 GMT 2006

I ran into another strange problem: when I try to invoke the ecosconfig tool
through the desktop icon, the ecosconfig tool window displays a bunch of
messages in its output window and then disappears. I dumped the output to a
text file, and it seems to complain that my installation doesn't contain the
"*.cdl" script (see below). 

---- from configtool output window ----

ecos.db, package CYGPKG_HAL: warning
    Version subdirectory `common' does not have a CDL script `hal.cdl'.
ecos.db, package CYGPKG_HAL: warning
    This package does not have any valid version subdirectories.

---- end from configtool output window ----

But I can see that there is an "
C:\cygwin\opt\ecos\ecos-2.0\packages\hal\common\v2_0\cdl" directory with
several .cdl files in it. 

I tried a few things but always got the same result:
a) invoke it directly from the cygwin shell command line (after executing
b) pull out the current version via anonymous CVS and run the configtool

Did I do anything wrong with my installation? Or did I miss some steps?
Thanks in advance!


-----Original Message-----
From: Andrew Lunn [mailto:andrew@lunn.ch] 
Sent: Friday, March 31, 2006 10:20 AM
To: Wayne Liu
Cc: ecos-discuss@sources.redhat.com
Subject: Re: [ECOS] Newbie question: eCOS and Redboot for AT91SAM7S-EK

On Fri, Mar 31, 2006 at 09:49:25AM -0700, Wayne Liu wrote:
> Andrew and Oliver,
> Thanks a lot for the information. I agree that RedBoot is not appropriate
> for such a platform. I always built my own bootloaders on such smaller
> embedded platform in the past. But was wondering if eCos must have RedBoot
> installed for its HAL is from Redboot.

eCos does not require RedBoot. Just build ROM applications.


Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list