[ECOS] Strange Problems !!!

Harsha D harshad@sanyo.co.in
Tue Sep 6 09:40:00 GMT 2005


Hi 

Currently i have a ram version of redboot running on my ARM platform.
(Redboot prompt is visible).
But none of the commands (like help, version, load) were working(redboot
hangs).  On debugging
i found that it was hanging at 

		(cmd->fun)(argc, argv);

in ecos/packages/redboot/current/src/main.c, after parsing the command.


So for debugging i put a printf inside the do_help function (in
main.cpp), to see if it was being called,
surprisingly help command worked!!!

void do_help()
{
	..

	diag_printf("\nInside do_help");

	..
	..
}

I tried removing the above printf.  and help didnot work !!!  I tested
it for 2-3 times. 

1.
Now i am worried as to how this printf is making the difference in
getting the output.
I think this must b the case for other commands too.

2.
Also i find that sometimes, the parse command looses the argument value.
i.e. although
"help" string is being sent when calling, inside the function the
argument has no value
at all

I am using gcc ver 3.2.1.  Please throw some light on the above issues.


regards
harsha

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list