[ECOS] Realtek 8139 problem

Gary Thomas gary@mlbassoc.com
Sun Mar 27 18:12:00 GMT 2005


On Fri, 2005-03-25 at 19:32 +0700, Umar Said wrote:
> Hi all, 
> 
> I have successfully build library for my modified PC target/template which 
> recognizes Realtek 8139 ethernet card. But when I try to compile some net 
> test program, an error occured. This was what I did:
> 
> $ i386-elf-gcc.exe -g -I pc_rltk8139_install/include/ ping_test.c -L 
> pc_rltk8139_install/lib/ -Ttarget.ld -nostdlib
> /opt/ecos/gnutools/i386-elf/bin/../lib/gcc-lib/i386-elf/3.2.1/../../../../i386-e
> lf/bin/ld: address 0xa2158 of a.out section .bss is not within region ram
> collect2: ld returned 1 exit status
> 
> My environment is Cygwin on Windows 2000 server. I got rltk8139.tgz from 
> http://ecos.sourceware.org/ml/ecos-devel/2003-07/msg00028/rltk8139.tgz. 
> Does anyone have any hints on this?

What template and startup type are you using?  It looks like you've 
tried to use a floppy startup which only uses low RAM and will not
be able to run larger programs, e.g. those with a networking stack.

Try using the 'net' template with a normal RAM startup.  You'll have
to have some way to load it onto your PC, e.g. RedBoot or GRUB.

Hint: you might think about updating to the latest CVS.  Support for
a PC+Realtek device have been in CVS for quite a while now.

-- 
------------------------------------------------------------
Gary Thomas                 |  Consulting for the
MLB Associates              |    Embedded world
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list