[ECOS] loading file on redboot

Rohan Soman rohan.soman@gmail.com
Tue Mar 15 03:44:00 GMT 2005


hello

>Why did you load it to 0x192670?  eCos code is linked to run at
>a fixed address (and I really doubt that this is it!)

>Try the command without the -b option and see if it helps.

When trying to load the image without the -b option i get following error msg:

RAM: 0x00100000-0x040f0000, [0x00192670-0x01000000] available
RedBoot> load -v -h 10.0.0.1 -m tftp hello
*** Abort! Attempt to load ELF data to address: 0x00108000 which is not in RAM
RedBoot> load -v -h 10.0.0.1 -m tftp hello.srec
*** Abort! Attempt to load S-record to address: 0x00003000, which is not in RAM
RedBoot>

-----------------------------------------------------------------------
i got the probelm fixed now. 

:)

previously i was starting redboot using GRUB (just because i wasn't
having more floppies to 'dd' redboot.bin) this is done using import
./packages/hal/i386/pc/current/misc/redboot_GRUB.ecm in current repository.
as i don't have much knowledege about internals of Redboot,GRUB i
thought that this would work but wasn't.

now when i use 'dd' and started redboot directly from floppy it's working fine.

i think this is what u was expecting to me speak about. but yesterday
my probelm wasn't fixed to write anything as a conclusion. now when i
have some conclusion in hand i think it's my duty to write u about. i
tried at my level to tell the conclusion i don't know about it's
correctness.


THANX LOT



------------

i want mention one more problem (), and waiting for ur ans.

i have created redboot.bin for i386 pc target with rtl ethernet from
the current repository.
this image is tarnsferred to floppy. this is working fine on my
machine as i said above.
but when tried to boot from the same floppy on my partner's machine it
starts up normally but not accepting the keyboard input. also doesn't
able to give ping response.

we both are using i386 pc machine with rtl ethernet cards though
machines are not exactly of same configuration.
  
though my work can be proceeded by using my machine as target and
partner's machine as host. i am eger to know what will i have to do
make me possible to use my partner's machine as target and my machine
as host. could someone help me.

  
- Rohan

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list