[ECOS] Re: insight can't connect to the redboot

tuyun twomol@126.com
Fri Mar 11 02:00:00 GMT 2005


nickg,hello!


     Yes,I have set remotebaud. But there is still nothing after command, and the logfile doesn't exist. The following is my commands:
        set remotebaud 115200
        set remotelogfile ~/gdb_log
		target remote com1

I just installed a linux  on my PC. On linux ,it works. On linux , I use the same commands, just change com1 to /dev/ttyS0.
The insight and gdb can connect to redboot successfully . There is the logfile's content when using gdb on linux:

w +$Hc-1#09
r -
w $Hc-1#09
r +$OK#9a
w +$qC#b4
r +$E02#a7
w +$qOffsets#4b
r +$#00
w +$?#3f
r +$S05#b8
w +$Hg0#df
r +$OK#9a
w +$g#67
r +$e42e0000010000000200000013000000d300000005000000060000000700000008000000090000000a000000fcff7f0c0000800cecff7f0c4c7a0000e82e000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000d3000000#e0
w +$mc7ffffc,4#62
r +$387a0000#c3
w +$m7a30,4#c8
r +$04b04ce2#24
w +$m7a34,4#cc
r +$00300fe1#ef
w +$m7a38,4#d0
r +$00400fe1#f0
w +$m7a3c,4#fb
r +$c04084e3#fb
w +$m7a40,4#c9
r +$04f029e1#fb
w +$m7a44,4#cd
r +$0fe0a0e1#52
w +$m7a48,4#d1
r +$00f0a0e1#1d
w +$m7a4c,4#fc
r +$00009fe5#f9
w +$m7a50,4#ca
r +$f60700eb#2a
w +$m7a54,4#ce
r +$fc9f000c#5b
w +
c q
w $k#6b
r +
End of log


>> Thank you very much !
>> I'm sorry I use cygwin. Does this also work on Cygwin? 
>> I do that similarly
>> (gdb) set remotelogfile ~/stablog
>> (gdb) target remote com1 


>Have you set the baud rate correctly? Do something like:

>(gdb) set remotebaud 38400

	

            Regards
 				

        tuyun
        twomol@126.com
          2005-03-10


More information about the Ecos-discuss mailing list