[ECOS] running apps from Angel, startup type RAM.

ecos@forumakad.pl ecos@forumakad.pl
Wed Mar 2 20:04:00 GMT 2005


Hello, 
 I'm trying to run/create eCos app that runs without redboot
initialisation, what I did was build "RAM" startup application, 
then define:
cdl_option CYGIMP_HAL_PROCESS_ALL_EXCEPTIONS {
	user_value 1
};
and undef:
cdl_option CYGSEM_HAL_USE_ROM_MONITOR {
		    inferred_value 0 0
};

 generally I tried following what redboot_RAM.ecm was doing, because this
loads and runs from Angel nicely.

 However loading and running apps created using that config end with
failure, so I attached gdb and tried to locate the problem... 
I "break cyg_startup", but after "step" the board just hangs..., I stepped
through those instructions and it looks like it hangs exactly when
entering 'warm_reset':

(gdb) x/i 0x0200808c
0x200808c <reset_vector+76>:	str	r1, [r0, #4]
(gdb) nexti  
0x0200808c in reset_vector ()
4: /a $r1 = 0x7e0
3: /a $r0 = 0xfffec000
(gdb) x/i 0x02008090
0x2008090 <warm_reset>:	mrs	r7, CPSR
(gdb) display /a $r7
5: /a $r7 = 0x0
(gdb) nexti <- here it hangs.

Additionally when stepping through those commands I noticed that LED blink
in strange pattern - first 4 light up, then they are all powered down, and
then exactly when it hangs, second led lights up.
 According to ARM docs, mrs r7,CPSR should 'get program status and put it
into $r7', I don't know why would that freeze the board...

 I don't know where I'm making mistake, but I just can't get this to work.
-- 
Dariush Pietrzak,
Key fingerprint = 40D0 9FFB 9939 7320 8294  05E0 BCC7 02C4 75CC 50D9

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list