[ECOS] RE: Unable to ping the EBD9312 board

Mukund JB. mukundjb@esntechnologies.co.in
Tue Mar 1 05:40:00 GMT 2005


Hello Burian,
Thanks for the reply

> Mukund JB. wrote:
> >
> > I have working on cirrus logic BSP & using EBD19312 board.
> 
> what's this (typo?), is there a new board available,
> I've just heard of EDB9312 boards so far.

It was a typo error I was speaking about EBD9312. 

> >
> > I have downloaded the redboot onto the board and redboot prompt
appears
> > on my minicom. As I don't have a BOOTP on my network(cross cabled),
> 
> crossover cables do not always work as expected, problems with
> autonegotiation maybe?
> 
> you could try to use a hub[1]/ switch[1] / different PC

I tried it with the HUB, it worked. The IP was assigned and I was able
to d/w the Linux kernel and run it. But when I tried the same later I
could not do it. The IP address is not assigned dynamically. I verified
all the DHCP connection, network connectivity but the problem persists.
WHY?

> 
> 
> > I
> > have configured the IP using ip_address command of redboot.
> >
> > The steps I followed are
> > 1) Connected to the host through cross cable (Host running tftp
server).
> > 2) D/W the Redboot using serial cable.
> > 3) executed the following command successfully
> > 	fis init -f
> > 	fconfig -i
> > 	ip_address -l 100.100.100.43 -h 100.100.100.13
> >
> > After that when I ping to HOST(100.100.100.13), it returns TIMED
OUT.
> 
> not really related to the problem, but is there a reason why you do
not
> use private IPs?
> 
> RFC 1918
> 
> 3. Private Address Space
> 
>     The Internet Assigned Numbers Authority (IANA) has reserved the
>     following three blocks of the IP address space for private
internets:
> 
>       10.0.0.0        -   10.255.255.255  (10/8 prefix)
>       172.16.0.0      -   172.31.255.255  (172.16/12 prefix)
>       192.168.0.0     -   192.168.255.255 (192.168/16 prefix)
> 
My entire network is Class A addressing. I.e 100.100.100.xxx
> 
> 
> 
> >
> > I am using a Intel 82557/8/9 ( cat/proc/pci entry shown card). I am
not
> > able to guess the problem.
> >
> 
> 
> You haven't told us what netmask you're using on each side.


I network uses 255.255.255.0
Also, the EBD9312 board redboot has a default subnet mask of 255.0.0.0.
This is a MISMATCH. 
However, we can do some thing when we first boot with redboot. DHCP
works at boot time. So, also if the subnet MISMATCH is the reason, can
we do any thing?

> 
> gateway?
> 
> If you've got a LAN with a DHCP server you could also try to configure
> redboot to use DHCP instead. If all the other PCs on the LAN work
> fine, using DHCP is an easy way to get a known good setup.

We got it when we used the DHCP. But problem now is we are unable to do
it the second time. Why?

Desperate to come out of this.

Regards,
Mukund jampala

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list