[ECOS] Networking Trouble
Dave Johnson
wickwack2003@yahoo.com
Wed Feb 9 20:35:00 GMT 2005
I am running an application built using the 'Net' template with the
ftp-client added. I want to connect to the server to download a file
and then put it back. The target is running RedBoot and I have been
uploading the application for test via GDB.
The problem is that while the Redboot IP remains pingable, I am not
even seeing a log entry in my FTP server from the application -- I
think the application networking may not be functioning.
I have configured the Redboot for 192.168.200.10, the application for
192.168.200.11, and the server 192.168.200.1. There is no gateway or
DNS services on the server; I just want to use IP to transfer files.
When I run the program, I see that "FTP Connect failed: Invalid
argument" and "FAIL:<ftp_get returned -3>".
Is there anything I need to do to activate ip other than
init_all_network_interfaces()?
Thanks,
Dave
__________________________________
Do you Yahoo!?
Yahoo! Mail - now with 250MB free storage. Learn more.
http://info.mail.yahoo.com/mail_250
--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
More information about the Ecos-discuss
mailing list