[ECOS] Re: Problem booting into ecos s-record file

Nick Garnett nickg@ecoscentric.com
Wed Apr 27 10:42:00 GMT 2005


Santanu Chatterjee <thisissantanu@gmail.com> writes:

> On 4/26/05, I <thisissantanu@gmail.com> wrote:
> 
> > But then what address should I give to the '-b' option?
> > Redboot is showing 0x0007bed0-0x000a0000 as the usable RAM (If I remember
> > correctly)
> 
> I have tried with many addresses within the range
> 0x0007bed0-0x000a0000, for the '-b' option, but they
> all seem to end in either a machine hang or a reboot.
> 
> I would greatly appreciate it if someone in this list could
> point me to some suitable document (online) that would 
> help me splve this.

Have you tried loading and running the ELF version of this application
via GDB? That will determine whether the application works, and is
usually the best way of running test applications.


-- 
Nick Garnett                                     eCos Kernel Architect
http://www.ecoscentric.com                The eCos and RedBoot experts


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list