[ECOS] Compiling and linking with ecos libraries and headers

Payam Refaeilzadeh iampayam@yahoo.com
Sun Apr 10 23:08:00 GMT 2005


I am kind of new to embedded developement using ecos. 
I was trying to compile and run a simple "hello world"
app on a MXLADS board but ran into some problems.  I
was able to compile this just fine and I was able to
load it on the board using gdb, but when I try running
it using the gdb continue command, it freezes on me. 
After disassembling and analyzing the loaded program I
discovered that when I compile and link my program
with the eCos libraries it includes many lines of
warm_reset code before the main method, which I don't
think belong there, and effectively it gets stuck
somewhere in that code, before it even gets to main. 
I am thinking I am not linking the "hello world" code
against the correct eCos libraries.  I have been using
the ecos configuration tool to create the eCos
libraries and I have already tried the "default" and
"all" package template, and have even tried the RAM
startup option hoping that this would get rid of the
warm_reset code, but have had no success.  I can use
GDB to jump to main and single step there, but just
using continue, it gets stuck.
Any thoughts?
Thanks

Payam Refaeilzadeh


		
__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!
http://smallbusiness.yahoo.com/resources/

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list