[ECOS] i386 boot problem

Gonçalo Antunes gmma@gmma.net
Mon Apr 4 14:01:00 GMT 2005


Please discard my last email...

My answer is: "I setup on the BIOS of the pc that the startup will be the 
floppy disk".
Is there any other configuration to be done on eCos configtool about that?

Thanks.



----- Original Message ----- 
From: "Gary Thomas" <gary@mlbassoc.com>
To: "Goncalo Antunes" <gmma@gmma.net>
Cc: "eCos Discussion" <ecos-discuss@ecos.sourceware.org>
Sent: Monday, April 04, 2005 2:52 PM
Subject: Re: [ECOS] i386 boot problem


> On Mon, 2005-04-04 at 14:48 +0100, Goncalo Antunes wrote:
>> hi!
>>
>> I'm working on a simple eCos application that will run on a standard i386
>> pc.
>> I configured the eCos installation with the "i386PC target" template and
>> built it.
>>
>> I wrote a simple hello world program, compiled it ok and then make the
>>
>> i386-elf-objcopy -O binary hello hello.bin
>>
>> and then:
>>
>> dd conv=sync if=hello.bin of=/dev/fd0
>>
>> for it to run booting from the floppy disk...
>>
>> but there is error when booting from the disk....:
>>
>> "Error 13: Invalid or unsuportted executable format".
>>
>> I formatted the floppy with the fdformat command before I used it...
>
> Did you set the startup type to be FLOPPY?
>
> -- 
> ------------------------------------------------------------
> Gary Thomas                 |  Consulting for the
> MLB Associates              |    Embedded world
> ------------------------------------------------------------
>
>
> -- 
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
>
> 



-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list