[ECOS] Intel Strata Flash TE28F128J3 Problem.

alfred hitch alfred.hitch@gmail.com
Mon Apr 4 07:16:00 GMT 2005


Hi,
If I am not wrong .. 
IXP425 based boards can have only 16Mb per chip select on expansion bus . 
which would mean u have 256 MB on different chip selects ??

Could that be the reason and how / what did you change to make this
256 instead of standard 16 MB which comes on IXdp425 boards (wasnt it
,, dont remember)

Cheers,
Alfred

On Apr 4, 2005 2:02 AM, Annamalai Prakash <prakash@comodo.com> wrote:
> Hi ,
> 
>               I wanted to bring up redboot with Intel's TE28F128J3C150 (256Mb)
> in my ixdp425 Board (ixp425 Xscale processor). I am using Intel Strata Flash
> driver which is integreated with ecos.  I am getting for Following output
> while board powerup/reset.
> 
> +FLASH configuration checksum error or invalid key
> No network interfaces found
> 
> RedBoot(tm) bootstrap and debug environment [ROM]
> Red Hat certified release, version 1.92 - built 14:54:46, Dec 30 2004
> 
> Platform: Interface Masters Kings Canyon 3 Board (XScale)
> Copyright (C) 2000, 2001, 2002, Red Hat, Inc.
> 
> RAM: 0x00000000-0x04000000, 0x0006b090-0x01fd1000 available
> FLASH: 0x50000000 - 0x51000000, 128 blocks of 0x00020000 bytes each.
> RedBoot>
> 
>                  PROBLEM is, After getting this Prompt, i am unable to
> initialize the flash by "fis init -f". The output is pasted below.
> 
> RedBoot> fis init -f
> About to initialize [format] FLASH image system - continue (y/n)? y
> *** Initialize FLASH Image System
> ... Erase from 0x50040000-0x50fc0000: ..............................Err = a2
> 
>    initialization failed 0x50400000: Error trying to erase
> ... Erase from 0x50fe0000-0x50fe0000:
> ... Erase from 0x51000000-0x51000000:
> ... Unlock from 0x50fe0000-0x51000000: .
> ... Erase from 0x50fe0000-0x51000000: .
> ... Program from 0x01fdf000-0x01fff000 at 0x50fe0000: Err = 92
> 
> Error writing FIS directory at 0x50fe0000: Error trying to program
> ... Lock from 0x50fe0000-0x51000000: .
> 
>                       I have tried to use "fc -i", It also giving the problem
> while programming.
> 
> RedBoot> fc -i
> Initialize non-volatile configuration - continue (y/n)? y
> Run script at boot: false
> Use BOOTP for network configuration: true
> Console baud rate: 115200
> DNS server IP address:
> GDB connection port: 9000
> Force console for special debug messages: false
> Network debug at boot time: false
> Default network device: i82559_eth0
> Network hardware address [MAC] for NPE eth0: 0x00:0x00:0x84:0x18:0x50:0x02
> Network hardware address [MAC] for NPE eth1: 0x00:0x00:0x84:0x40:0x50:0x02
> Update RedBoot non-volatile configuration - continue (y/n)? y
> ... Unlock from 0x50fc0000-0x50fc1000: .
> ... Erase from 0x50fc0000-0x50fc1000: .
> ... Program from 0x01fd2000-0x01fd3000 at 0x50fc0000: Err = 92
> 
> Error writing config data at 0x50fc0000: Error trying to program
> ... Lock from 0x50fc0000-0x50fc1000: .
> 
>                       Any Input regarding this problem will be appreciated ...
> 
> Thanks & Regards
> K.Annamalai Prakash
> 
> --
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
> 
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list