[ECOS] Error: Socket was forcibly closed by remote host

Andrew Lunn andrew@lunn.ch
Wed Sep 29 11:19:00 GMT 2004


On Wed, Sep 29, 2004 at 03:24:05PM +0530, Vijay Padiyar wrote:
> Hi all
> 
> We are facing a strange problem. We first run the Redboot monitor with
> Ethernet support and obtain the Redboot prompt. Then we load the application
> image obtained by compiling 'hello.c' with 'init_all_network_interfaces()'
> and the net template build in eCos Config Tool.
> 
> When the Redboot monitor executes, it is able to successfully get the IP
> address from a BOOTP/DHCP server. But when we execute the kernel image, it
> sends a BOOTP request to the BOOTP server, and the BOOTP server even
> responds to it (we can see this in the BOOTP log window), but then the BOOTP
> server flashes a dialog saying "Error: Socket was forcibly closed by remote
> host". And the terminal window shows "BOOTP/DHCP failed on eth1". We are
> using FCC2/eth 1 for our board.

Redboot and the applications need to have different IP addresses. One
way to do this is to use bootp for redboot and DHCP for the
application. You can then configure your servers so that they give out
different addresses. Do you have this setup or do you assign the same
IP address to both redboot and the application.

        Andrew

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list