[ECOS] jffs2 filesystem issues

Ashish Chopra ash_ecos@yahoo.com
Fri Sep 17 00:33:00 GMT 2004


hi all
 
I have successfully installed the flash filesystem
using the test fileio.c program which is doing
whatever its intended to do perfectly.

Problem is when i run program for first time after
that jffs image is again written in block after 64kb
but without the node header.

say if my image in flash is at location 
0x1040000 
then after i run the program, at location 
0x1050000 , then at 0x1060000 ......so on,jffs.img
is written which causes the "magic bitmask 0x1985 not
found at...." warnings when i run the program second
time and so forth. Program works fine even after the
warnings but how to solve this problem of copying of
image at some other location after the first run of
program.

Thanks in advance
Ashish


		
__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail 

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list