[ECOS] Running redboot from RAM using JTAG on a new custom target

Vanitha Ramaswami vanitha@agilis.st.com.sg
Tue Sep 7 06:58:00 GMT 2004

Hi All,

I have a custom board based on the ADI GRG board. I have modified the 
redboot source code for the custom board and having a compiled 
redboot_RAM.bin. I downloaded the RAM version of redboot to the address 
0x1000 and gave go. I am getting some hardware breakpoint.

How do i load redboot thro' JTAG and run from RAM ?. I dont have a working 
redboot on FLASH, since its a custom board and i need to debug redboot., I 
appreciate any inputs on this.

I am using EPI MAJIC emulator and using the following commands to run 

1) fr m redboot_ram.bin 0x1000

2) g 0x1000

Then getting hardware instruction breakpoint. I tried the RAM version of 
redboot what i got from ADI, in the ADI GRG board without the flashed 
redboot. Even here getting the same error.


Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list