[ECOS] segmentation fault in ld

Edgar Grimberg edgar.grimberg@rms.ro
Mon Nov 22 12:34:00 GMT 2004


Hi,
I am using arm-elf tools

[edgar@wks-edgar code]$ arm-elf-gcc --version arm-elf-gcc (GCC) 3.2.1 
(eCosCentric) Copyright (C) 2002 Free Software Foundation, Inc. This is 
free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 
[edgar@wks-edgar code]$ arm-elf-ld --version
GNU ld version 2.13.1 (eCosCentric)
Copyright 2002 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.

and I have the following problem...

[edgar@wks-edgar code]$ arm-elf-gcc -mcpu=arm7tdmi -mno-short-load-words 
-Wl,--gc-sections -Wl,-static -g -nostdlib -nostartfiles 
-L/home/edgar/mycvs/ecos/applib-ts/install/lib -Ttarget.ld  bin/main.o 
bin/guiarea.o bin/guibutton.o bin/guibutton3d.o bin/guibuttonflat.o 
bin/guicombo.o bin/guicomponent.o bin/guicontainer.o bin/guievent.o 
bin/guiimage.o bin/guilabel.o bin/guipoint.o bin/guitextedit.o 
bin/lcddriver.o bin/sed1335f.o   -o ./bin/main.elf
collect2: ld terminated with signal 11 [Segmentation fault], core dumped

Issuing the same command for some other .o files makes the output elf 
file with no problems at all.
My SO is Fedora Core 2.

Thanks,
Edgar

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list