[ECOS] Strange error when building for floppies, using the RLTK 8139 driver

Gregg C Levine landocalrissian@att.net
Sun Nov 21 20:10:00 GMT 2004


Hello from Gregg C Levine
For the obvious reasons I am attempting to build a floppy image using the
Realtek 8139 driver. 

I imported the floppy configuration file using the GUI based configuration
builder for eCos and started the build process off for the I386 platform.

This is using the Cygwin platform on Win2K. 
Everything went well, until it hit the snag in the fragment below. That's
the
tail of the output file. This is from the CVS stores as of early this
morning.
-------
Gregg C Levine landocalrissian atsign att dot net

-----------
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c
In file included from
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:97:
/ecos-c/cygwin/usr/src/tests/test3_install/include/pkgconf/devs_eth_rltk_813
9.h:11:10: #include expects "FILENAME" or <FILENAME>
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:134:
2: #error "CYGDAT_DEVS_ETH_RLTK_8139_INL not defined"
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:591:
warning: `rltk8139_init' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:775:
warning: `rltk8139_control' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:864:
warning: `rltk8139_can_send' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:875:
warning: `rltk8139_send' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:991:
warning: `rltk8139_recv' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:1267
: warning: `rltk8139_poll' defined but not used
/usr/src/anoncvs/ecos/packages/devs/eth/rltk/8139/current/src/if_8139.c:1292
: warning: `rltk8139_int_vector' defined but not used
make[1]: Leaving directory
`/ecos-c/cygwin/usr/src/tests/test3_build/devs/eth/rltk/8139/current'
make[1]: *** [src/if_8139.o.d] Error 1
make: Leaving directory `/ecos-c/cygwin/usr/src/tests/test3_build'
make: *** [build] Error 2


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list